Master Bug Reporting Thread for the New Wiki

Avatar image for cloudguy
Cloudguy

2757

Forum Posts

2139468

Wiki Points

0

Followers

Reviews: 21

User Lists: 22

Avatar image for lvenger
Lvenger

36390

Forum Posts

899

Wiki Points

0

Followers

Reviews: 50

User Lists: 18

No numbers on notifications or inbox when you have messages.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#153 pikahyper  Moderator

@cloudguy: looks like another bug just for regular users, looks normal with my mod account but shows double for my regular accounts.

Avatar image for cloudguy
Cloudguy

2757

Forum Posts

2139468

Wiki Points

0

Followers

Reviews: 21

User Lists: 22

@pikahyper: I wonder why bugs affect mods differently for such simple things.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#155 pikahyper  Moderator

@cloudguy: for that bug specifically it probably has something to do with being able to move episodes, that's the field.

Avatar image for darthant66
DarthAnt66

2560

Forum Posts

969

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

Imgur .gifvs are currently not loading and frozen at the first frame for me (.gifs work fine). Example:

Loading Video...

Please fix. Thanks!

Avatar image for cloudguy
Cloudguy

2757

Forum Posts

2139468

Wiki Points

0

Followers

Reviews: 21

User Lists: 22

@darthant66: While I understand that it's annoying that things don't work. Quoting yourself won't get it fixed quicker, if you've read the thread in anyway, you'll see how many site "breaking" bugs we have at the moment that need prioritizing. It'll get fixed, just give it patience, we're on day 2 of the new site.

Avatar image for darthant66
DarthAnt66

2560

Forum Posts

969

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#158  Edited By DarthAnt66

@cloudguy said:

@darthant66: While I understand that it's annoying that things don't work. Quoting yourself won't get it fixed quicker, if you've read the thread in anyway, you'll see how many site "breaking" bugs we have at the moment that need prioritizing. It'll get fixed, just give it patience, we're on day 2 of the new site.

On the flip side, it (demonstrably) draws more attention to the problem. ;)

Avatar image for cloudguy
Cloudguy

2757

Forum Posts

2139468

Wiki Points

0

Followers

Reviews: 21

User Lists: 22

@darthant66: Well, yes and no. Unlike many of the other bugs on the site which stop features from being used, not working as intended or can create problems. Gifs not working isn't the end of the world. I agree that it does bring more attention to the problem, but bigger ones have to be prioritized.

Avatar image for darthant66
DarthAnt66

2560

Forum Posts

969

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

#160  Edited By DarthAnt66

@cloudguy said:

@darthant66: Well, yes and no. Unlike many of the other bugs on the site which stop features from being used, not working as intended or can create problems. Gifs not working isn't the end of the world. I agree that it does bring more attention to the problem, but bigger ones have to be prioritized.

.Gifvs (.gifs work fine) not working render many respect threads absolute, making debating (a central part of the site) difficult and hours/days/weeks/months of work null.

Of course, I never said it's the most important issue pressing the site.

Avatar image for cloudguy
Cloudguy

2757

Forum Posts

2139468

Wiki Points

0

Followers

Reviews: 21

User Lists: 22

@darthant66: Oh yeah, I definitely agree that it's an important part of the user community and needs to be fixed. But that'll happen in due time.

The wiki got the biggest rework while the forums what what I can see, was left basically untouched.

Once that majority of major issues are fixed, the smaller ones will be worked on. No clue when, but it will be given time.

I'm not a mod or staff, I'm a user just like you so I understand how irritating it can be for work to be temporarily nullified, but we need to put the wiki before the forum. I'm not saying it's not relevant, the engineers just need to focus on more important matters.

Avatar image for sirfizzwhizz
SirFizzWhizz

37749

Forum Posts

0

Wiki Points

0

Followers

Reviews: 0

User Lists: 1

I have a issue and bug.

No Caption Provided

As seen, when I type larger post, and it starts to scroll down, the tool bar for images, font, ect are all hidden by the annoying wiki/new comics/ect header. Forcing me to scroll all the way up to hit a spoiler block or font.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#163 pikahyper  Moderator
Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#164 pikahyper  Moderator

The Create page for Publishers is missing, 500 error. Browse>Publishers>sidebar. The Quick Add works just no full page.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#165  Edited By pikahyper  Moderator

New search bar interface sssssuuuuuccccckkkkkks if you search a lot, any chance of binding a keyboard shortcut to the search bar to open it with a key combo???

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#166 pikahyper  Moderator

Sometimes creating a new page is zero points.

Avatar image for cloudguy
Cloudguy

2757

Forum Posts

2139468

Wiki Points

0

Followers

Reviews: 21

User Lists: 22

The episode appearances links are broken on character pages.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#168 pikahyper  Moderator

When adding associations if you add the same one twice you get a generic Unknown Server Error instead of a more useful and descriptive error message.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#169  Edited By pikahyper  Moderator

Big submissions for issues are a mess, big as in lots of changes in multiple areas. I just filled in an issue with 32 "changes"; deck, description, creators, characters, teams, story arc, issue title, cover date and in-store date. When I hit Submit All Changes it processed for a second then an error about the object type not being on the page dropped down (I think this is Cover Date related). I tried to Submit again and started getting new errors about the item already being on the page, when I looked at the live view about half of the "changes" had gone through but were still in the hud as new, I tried removing the already processed changes from the hud but eventually had to give up and just delete everything in the hud and start over with the live page that was already half done.

Edit: Happened again but this time it says "This changeset has already been finalized", 15 changes and looking at the live page only two changes are showing, I've removed those two changes from the hud and the edit still won't go through, have to start over again...

Edit Again: Now it has a problem with creating multiple stubs in the same edit, creates the first one (but doesn't add it to the parent page) then Unknown Server Error. This is getting old.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#170 pikahyper  Moderator

If you are editing a wiki page and someone edits it while you are and submits it the editing you do throws errors about it already being part of the page, if you don't know better you think you made a mistake, this just happened to me and I only figured it out by opening the live page in another tab to see someone had filled in associations so that when I tried to add those same associations I got the error. The wiki needs better "collision" detection, maybe lock the page while it is in edit mode for anyone else that tries to edit with an error message that someone is editing the page.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#171  Edited By pikahyper  Moderator

For the wiki toolbar can the Done/Cancel buttons be moved up next to the More button? It is really annoying having so much vertical space taken up that gets even worse if you click More and have three rows open. Having only one row total (including the More row) would be ideal but it might not fit in the wiki, it would fit in the forum.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#172 pikahyper  Moderator

Stub pages that get created from a submission that glitches have no default image of any kind, example. This might be cause I unintentionally deleted the Blank image but probably not since stubs created without a glitch at least show the broken image as its default.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#173  Edited By pikahyper  Moderator

Suggestion: Your notification and unread PM count should show in the tab bar next to the CV favicon, like how gmail does it, [icon]x/x, notifications first/then unread PMs, if both are zero it just displays the favicon.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#174 pikahyper  Moderator

Creating stub story arcs is broken, it creates them without a default and doesn't attach it to the parent page, error message is an Unknown Server Error. Currently have to manually add the parent issue page on the arc page.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#175 pikahyper  Moderator

Ok weird bug, if I create a new page, manually or as a stub I'm added as the Top Contributor with 50 points for creating the page (as expected), there is no record of the page creation in the wiki history though (not expected, it used to show the initial creation edit in the old history), now if the next edit on the page is from another editor I'm dropped from the top contributors and replaced by who made the edit (only the other editor is displayed), now if it is me that makes the next edit on the page I replace myself as the 50 point top contributor and it stills shows me but the point total is only the new point total i.e. original edit is 50 points, next edit is 200 points the top contributor box will show me with the total points being 200 instead of 250 so basically the creation edit is being forgotten the next time the page is edited by anyone.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#176  Edited By pikahyper  Moderator

I'm starting to see why big edits keep failing, when fields get closed it looks like it is finalizing and saving it and then if you go back and open the field again to add more and then submit the edit the stuff that finalized in the background is trying to submit again causing the error, so basically you can only work in a section one at a time in an edit so for example you can't add some creators, then add some characters, then add a date (hitting done for a date field closes the other fields), then go back and add some more creators as you will get an error when you Submit All "People: This entity does not have the association you are trying to edit", removing the creators from the page to try and save the rest will not work you have to clear everything out of the hud and start over from scratch. Ridiculous, you literally get penalized for making big edits now, the only work around is to make several edits to a page to fill it; fill in a couple of sections, Submit All, fill in another section or two, Submit All, fill in some more, Submit All, instead of one edit I have to make five or six....

Edit: Does it auto-save every ten associations added? What's with the asterisk that gets added next to creator roles? they seem to appear every ten added. I just added 24 creators, the first ten are showing up on the live page before submitting and the first 20 have asterisks next to their roles and I can't submit.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#177  Edited By pikahyper  Moderator

Using the Quick Add is broken, it creates the page but throws an Unknown Server Error and doesn't attach a default image.

Edit: A lot of the full Create pages are down too, 500 error.

Avatar image for wcarle
wcarle

170

Forum Posts

495

Wiki Points

0

Followers

Reviews: -1

User Lists: 0

#178 wcarle  Staff

We released a lot of fixes today including:

Fixed quick add and full create pages
Submission queue had stuck submissions when creating new entities, this is fixed
Added missing info back to volumes and issues (episodes and series to come soon)
Various homepage style issues (button color, padding, centering, etc)
Editor controls blocked by the main site menu (and other things blocked by it)
Search indexing wasn't fully working for wiki entities
Item statistics were not being updated properly
Various other small fixes.

We're continuing to work on fixes and will provide updates here as we release them.

Avatar image for cloudguy
Cloudguy

2757

Forum Posts

2139468

Wiki Points

0

Followers

Reviews: 21

User Lists: 22

@wcarle: Any chance on an explanation of how the Page Needs Help feature works?

Avatar image for wcarle
wcarle

170

Forum Posts

495

Wiki Points

0

Followers

Reviews: -1

User Lists: 0

#180  Edited By wcarle  Staff

@cloudguy said:

@wcarle: Any chance on an explanation of how the Page Needs Help feature works?

It's pretty simple. When someone requests help on a page it it adds to a counter. The wiki objects with the highest number of requests for help appear on the home page. Then the counter for each item lowers over time so they eventually disappear off the page unless more people request help on them

Avatar image for cloudguy
Cloudguy

2757

Forum Posts

2139468

Wiki Points

0

Followers

Reviews: 21

User Lists: 22

@wcarle: Right ok, that's simple enough. Is there a chance you can add a section in which a user can type what's needed to be helped on that page, as some basically complete pages have been added and from looking at them, I'd have no idea what needs changing, unless I was the user who clicked that button.

Would mods be able to remove the help once it's been completed and up to standard?

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#182  Edited By pikahyper  Moderator

@wcarle said:

Added missing info back to volumes and issues (episodes and series to come soon)

Most of that extra info should be centered:

  • Browse>Volumes, this one is a bit wonky the three things are back (Cover Date, Issue Count, Publisher) but it is inconsistent, it looks like volumes added after the update had correct counts but then that stopped, there is one from the 10th with 10 issues with a zero count and there are some with zero issues that just say "Issues" instead of "0 Issues", all the fields should be centered though
  • Browse>Issues is showing everything it should but Cover Date should be centered.
  • Browse>Series, still missing Start Year, Publisher and episode count, all extra fields should be centered
  • Browse>Episodes, still just showing the episode title so it is missing Series name, episode number and air date, air date should be centered
Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#183 pikahyper  Moderator

Looks like the Browse pages that start with Popularity default are broken, page one shows 44 items as expected but if you hit page 2 it'll load for a while and then the results are the second page of alpha order sort instead of popularity.

Also to go along with post #182 above, the Popularity issues page is missing the Cover Date. And Browse>Characters and Browse>Teams should probably show the Publisher centered below the deck text.

And issues and episodes still have that pesky title requirement added with a three character minimum, that needs to be gone still.

Avatar image for cloudguy
Cloudguy

2757

Forum Posts

2139468

Wiki Points

0

Followers

Reviews: 21

User Lists: 22

Not sure if this is a bug or feature that wasn't intended for mobile. I'm able to add issues to volumes via mobile. The formatting is half-working on mobile for the add page section.

I'm not able to edit what I add though.

Avatar image for cloudguy
Cloudguy

2757

Forum Posts

2139468

Wiki Points

0

Followers

Reviews: 21

User Lists: 22

This is a long standing bug since the previous version of the site. If I use the issue top menu that allows me to see other issues while on an issue page, it goes back to early pages once I get towards the end of a volume which slowly becomes a problem if I'm editing or wanting to look through each page as I'd have to go to the main volume page and click the issue from there, rather than the issue toolbar.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#186  Edited By pikahyper  Moderator

In-Store Dates can't be deleted only changed once one exists. To be clear no In-Store can stay no In-Store, has an In-Store can't be changed to no In-Store, has an In-Store can only be changed to another In-Store. If you delete an In-Store date there is no error the Done button just doesn't do anything if you click it. We need to be able to delete In-Store dates and leave it empty..

Avatar image for cloudguy
Cloudguy

2757

Forum Posts

2139468

Wiki Points

0

Followers

Reviews: 21

User Lists: 22

#187  Edited By Cloudguy

There are a few odd occasions where I've added creators, Characters, etc. And when I've hit done. It says i can't progress because one or more associations don't have pages. Even though I've got them through the search feature and not made them. Removing all issue associations fixes this as far as I've found.

Avatar image for fables87
fables87

1791

Forum Posts

1054918

Wiki Points

0

Followers

Reviews: 54

User Lists: 0

I've been having issues add photos to wiki pages. When I go to add a photo, the photo will load to my page, but not the wiki page itself. I then try to re-add the photo from previous uploads and it doesn't work either. I keep getting a "An error occured while uploading the image" message. Is anyone else having similar issues or is it just me?

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#189 pikahyper  Moderator

Most of the time when you edit an issue page that has a previously saved fuzzy date all three fuzzy date fields will be empty, nothing is being changed it just doesn't show the saved data while in edit mode.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#190  Edited By pikahyper  Moderator

There is a problem with image links from a gallery. If you go into a pages gallery and click an image "images" will be in the url twice "https://comicvine.gamespot.com/sentry/4005-1454/images/images/1300-5107634" now if you copy that url and try to paste it it will redirect to the parent page of "https://comicvine.gamespot.com/sentry/4005-1454/".

Now the url doesn't always go images/images sometimes it will do images/image id/images/.

All in all it means we can't give links to images in the image viewer for galleries, you have to right click the image and open it directly in a tab and share that url.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#191 pikahyper  Moderator

Issue counts for volumes isn't updating.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#192  Edited By pikahyper  Moderator

@fables87 said:

I've been having issues add photos to wiki pages. When I go to add a photo, the photo will load to my page, but not the wiki page itself. I then try to re-add the photo from previous uploads and it doesn't work either. I keep getting a "An error occured while uploading the image" message. Is anyone else having similar issues or is it just me?

I am too, looks like wiki galleries are broken, might have something to do with post #190.

Images can't be uploaded from desktop, a url or previous uploads but you can add them if they already exist on the site via Search the Site. This problem only effects wiki galleries though, all options work in the forum and you can add images to issues and while creating a wiki page.

Edit: This might not be happening to all page types or might not be happening to all users, not sure which as another user is able to upload images from desktop to a concept page, I only tried with creator and character pages.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#193  Edited By pikahyper  Moderator

The Needs Help page needs an overhaul, it is already being abused, most of the pages either don't need help, will never get help or just need a little bit of updating. It feels like most people are just clicking the button to see what it does and it is being done maliciously to bring up pages that are inappropriate. We need three things added to the feature before it should be used any more:

  1. A mandatory comment system that attaches to the page. We need feedback to know what is wrong with a page. Ten words minimum requirement and if they just type gibberish don't count it and ban them from the wiki for a little while. Should be easy enough to output the comment below the item on the Needs Help page.
  2. Usernames need to be attached somehow. Take away the anonymity and decrease abuse. Easiest way would be to have a mouse-over pop-up with a simple unordered list of the usernames that clicked the button for that page, you could even include the comment next to the username in the pop-up that way multiple comments can be viewed with them associated with the usernames.
  3. Mods and staff need to be able to override it or reset it back to its normal status. Just put an overlay icon in the bottom right corner of each item of a little "x" just like how we delete issue and episode images, only visible to mods and staff.

Edit: And I'm not sure if it already has this feature but if it doesn't it really should: limits, there should be a per day limit to how many times a user can click a single Needs Help button and how many different buttons per day, maybe link it to the karma system, click a Needs Help button your karma goes up, click too many and you can't click anymore for the day.

Avatar image for cloudguy
Cloudguy

2757

Forum Posts

2139468

Wiki Points

0

Followers

Reviews: 21

User Lists: 22

@pikahyper: I second this. Although, I feel that we should maybe have a limit to how many pages need help at once.

Avatar image for noldrek
noldrek

2

Forum Posts

11702

Wiki Points

0

Followers

Reviews: 0

User Lists: 0

When you click on "n appearances" for a character, it shows you every issue of the selected volume, not just the ones in which the character appears.

Avatar image for cloudguy
Cloudguy

2757

Forum Posts

2139468

Wiki Points

0

Followers

Reviews: 21

User Lists: 22

The top contributors of the week isn't working properly. Points are slowly being deducted. The other day I was on 10k points and now i'm on 8k.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#197  Edited By pikahyper  Moderator

My Wiki Contributions from the HUD is inconsistent, right now for me it just shows two submissions from 4 days ago, earlier today it showed dozens but they were all random too: some recent, some a day old and some older. Showing my past history is pretty useless but it might as well work better.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#198  Edited By pikahyper  Moderator

Adding creators is still hit or miss, I needed to add 49 creators with roles, I added them all and hit Submit only to get an error "People: This entity already has the association you are trying to add/revert", 14 of them were already added so I have to start over again and manually delete all 56 changes from the HUD and clicking the trash can doesn't always work. I'm seeing that stupid error message way too often. The page also gets super bogged down and slow, typing out 49 full names because search sucks for partials is bad enough without it slowing down my browser as well.

I know this is a difficult bug but it needs to be a higher priority, most of the stuff getting fixed is easy and doesn't interfere with editing nearly as much as this creator problem and this is wasting way more of my time when I have to fill in large pages multiple times or manually delete things from the HUD when it takes up to 30 seconds to remove each item.

The HUD needs some kind of reset to clear out changes, in the old days we could just refresh the page and start over but not anymore, even leaving edit mode doesn't do anything since the HUD saves everything.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#199 pikahyper  Moderator

If a user starts following you you get two notifications, the newer one has a timestamp and the older one doesn't.

Avatar image for pikahyper
pikahyper

18565

Forum Posts

28238093

Wiki Points

0

Followers

Reviews: 5

User Lists: 456

#200 pikahyper  Moderator

What's with all the extra buttons in edit mode for regular users, have those always been there? four buttons for each association field?