Avatar image for arkay74
#1 Posted by arkay74 (100 posts) - - Show Bio

Half of the stuff it doesn't seem to find at the moment, for example plenty of Spider-Man books (Amazing Spider-Man Epic Collection, etc.). When I enter the same search query on the webpage I found those books without any problems.

So as a I workaround I have to come here, retry the seach on the webpage and then paste the resulting ID into the CV Scraper search dialog to find the entry.

Any ideas what changed?

Avatar image for krandor
#2 Posted by krandor (11 posts) - - Show Bio

The two specific things I've noticed is that searches of more then one word seem to not work corrrectly (if at all) right now. Have to keep a search to one word (and therefore get lots of results) for it to return much of any data. Also, dashes do not seem to work in a search either. So a search for spider-man fails, but a spiderman search works.

Avatar image for arkay74
#3 Edited by arkay74 (100 posts) - - Show Bio

Seems to be the same problem with colons, if you enter a term that follows it you are not getting results back.

If you search for "Avengers: X-Sanction" and enter "Avengers X-Sanction", the search fails. With only "Avengers" it works.

A more complicated example for "Angry Birds Quarterly: Monsters and Mistletoe"

The API query sent by the scraper:

angry AND birds AND comics AND quarterly AND monsters AND mistletoe -> 0 results

angry AND birds AND comics AND quarterly -> 1 result, wrong volume, not "Monsters And Mistletoe"

Through the wiki search:

Angry Birds Quarterly Monsters and Mistletoe -> Correct entry Found

Avatar image for btxcv
#4 Posted by btxcv (2 posts) - - Show Bio

For me, I can do some multi-word searches, but I haven't had it return a single result when I specify an issue number (in a search for issues). For example:

https://comicvine.gamespot.com/api/search/?api_key=<api_key>&format=json&resources=issue&query=Bad+AND+Machinery+AND+%235&page=1

... returns no results. I tried with the issue number in various formats, none successfully.

Hopefully someone can say what's going on. Thanks!

Avatar image for oscillator
#5 Posted by oscillator (1 posts) - - Show Bio

Just checking in to say I'm having the same issue.

Avatar image for Mike_Matrix
#6 Edited by Mike_Matrix (1 posts) - - Show Bio

Yep, I'm having the same issue too, I will have to input one word titles for it to work correctly, like if it searches for "Hellboy - The Midnight Circus" it comes up with nothing, but if i put in just "Hellboy" it brings me to what I'm looking for. Any help on this would be appreciated.

Avatar image for pikahyper
#7 Posted by pikahyper (18268 posts) - - Show Bio

@arkay74: CV has a new search engine, it has relevancy problems that are being worked on.

Moderator
Avatar image for arkay74
#8 Posted by arkay74 (100 posts) - - Show Bio
Avatar image for pikahyper
#9 Posted by pikahyper (18268 posts) - - Show Bio

@arkay74: there is actually a thread over on GiantBomb in their Bug Reporting forum for the new engine, it might be helpful for you and your plugin to chime in there since engineers rarely visit CV.

Moderator
Avatar image for arkay74
#10 Posted by arkay74 (100 posts) - - Show Bio

@pikahyper: Thanks, that's good to know! I will take a look.

Avatar image for pikahyper
#11 Edited by pikahyper (18268 posts) - - Show Bio

@arkay74: one would think having a new search engine wouldn't interfere with the API but anything is possible here lol, the CBSi people love the API though so I'm sure the engineers would want to know if search is potentially messing with it.

Moderator
Avatar image for btxcv
#12 Posted by btxcv (2 posts) - - Show Bio

Oh thank you very much for pointing me in the right direction, and I'm relieved that there's an explanation for the oddness I've noticed.

Avatar image for krandor
#13 Posted by krandor (11 posts) - - Show Bio

@arkay74: one would think having a new search engine wouldn't interfere with the API but anything is possible here lol, the CBSi people love the API though so I'm sure the engineers would want to know if search is potentially messing with it.

I added some comments on the API issues in the GB thread. Hope they get all these search issues worked out soon. From reading the GB thread, sounds like the search changes are causing other issues here at CV.

Avatar image for arkay74
#14 Posted by arkay74 (100 posts) - - Show Bio

@pikahyper: Always depends on how deep said new search engine is integrated. If it's being used by the website and the API then it makes sense :)

Avatar image for arkay74
#15 Posted by arkay74 (100 posts) - - Show Bio

If anyone would like to hack his scraper, then commenting out a line of code makes the search work much better. Seems that putting an " AND " between each term is what causes problems.

I commented out line 66 in C:\Users\<your username>\AppData\Roaming\cYo\ComicRack\Scripts\Comic Vine Scraper\cvconnection.py:

Changing from:

searchterm_s = " AND ".join( re.split(r'\s+', searchterm_s) ); # issue 349

to:

# searchterm_s = " AND ".join( re.split(r'\s+', searchterm_s) ); # issue 349

It doesn't work as well as it did before, but at least now I don't have to come here and do a query for every 3rd book or so.